Access Is Denied on Mklink

I am trying to get a symlink working over a network drive.

I have already tried suggestions on questions already asked, such as running as administrator and checking if the directory already exists. Unfortunately it still gives me the following error:

C:\Windows\system32>mklink /d \\myserver\someLink \\myserver\mydir
Access is denied.

Any ideas how I could get this working? The local machine is running windows 7 and the remote machine is running windows server 2008 R2 standard.

3 Answers

I jumped through all the hoops:

  1. Create a non-admin account (in my case, activated the guest account).
  2. As Admin, run secpol.msc and grant this account Create Symbolic Link permissions.
  3. runas /user:guest cmd to open a command window as the guest.

    only to get caught on the simplest problem: because I was running as guest, I didn't have write permissions within the directory. So,

  4. As admin, change permissions in the target directory (where you want to make the link) to give write access to the non-admin user.

2

I had this while I wanted to create a hard link with mklink /H .... By removing the /H, the error vanished as well.

So if a symbolic link does the trick for you as well, you should try this.

This is a little silly, but make sure you're using /D (soft) or /J (hard) for directories or you'll get access denied.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

James H. Sterling

James H. Sterling

Environmental Science & Climate Journalist

James Sterling reports on renewable energy developments, climate policy, ecological conservation, and green tech innovations around the globe.

Share this article
Twitter Facebook Pinterest