Apache: Invalid Command 'Sslengine', Perhaps Misspelled or Defined by a Module Not Included in the Server Configuration
When Configure Apache2 Virtual Hosts for Ssl/Https Connection, After Adding Configuration and Enable the Configuration with This Command " A2Ensite Pm...
When configure apache2 virtual hosts for ssl/https connection, after adding configuration and enable the configuration with this command " a2ensite pm.university.com.conf " i got this error "Invalid command 'SSLEngine', perhaps misspelled or defined by a module not included in the server configuration". I will answer my own question.
5 Answers
It turned out I did enabled ssl module but i had to do it again and it works, here is the command:
sudo a2enmod ssl
Now restart apache like so service apache2 restart
no more error, FIXED!
sudo a2enmod ssl
and restart the apache service that will do the trick
Invalid command 'SSLEngine', perhaps misspelled or defined by a module not included in the server configuration
Simply:
This error likely happens on apache if your "virtual host" is trying to use SSL but you did not install SSL module on your apache.
Must Read
Case 1: For Centos (linux distro), run:
yum install mod_ssl openssh