Could Not Reserve Enough Space for Object Heap
I Am Getting the Following Exception Repeatedly Each Time I Try to Run the Program. Error Occurred During Initialization of Vm Could Not Reserve Enough Space...
I am getting the following exception repeatedly each time I try to run the program.
Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine.
I tried to increase my virtual memory (page size) and RAM size, but to no avail.
How can I eliminate this error?
27 Answers
Run the JVM with -XX:MaxHeapSize=512m (or any big number as you need) (or -Xmx512m for short)
This can also be caused by setting something too large on a 32-bit HotSpot vm, for example:
-Xms1536m -Xmx1536m
where this might/would work:
-Xms1336m -Xmx1336m
here is how to fix it:
Go to Start->Control Panel->System->Advanced(tab)->Environment Variables->System
Variables->New: Variable name:
_JAVA_OPTIONSVariable value:-Xmx512MVariable name:Path
Variable value:%PATH%;C:\Program Files\Java\jre6\bin;F:\JDK\bin;
Change this to your appropriate path.
I ran into this when using javac, and it doesn't seem to pick up on the command line options,
-bash-3.2$ javac -Xmx256M HelloWorldApp.java
Error occurred during initialization of VM
Could not reserve enough space for object heap
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
so the solution here it so set _JAVA_OPTIONS
-bash-3.2$ export _JAVA_OPTIONS="-Xmx256M"
-bash-3.2$ javac HelloWorldApp.java
Picked up _JAVA_OPTIONS: -Xmx256M
And this compiles fine.
This happens to me on machines with a lot of RAM, but with lower memory ulimits. Java decides to allocate a big heap because it detects the ram in the machine, but it's not allowed to allocate it because of ulimits.
32-bit Java requires contiguous free space in memory to run. If you specify a large heap size, there may not be so much contiguous free space in memory even if you have much more free space available than necessary.
Installing a 64-bit version of Java helps in these cases, the contiguous memory requirements only applies to 32-bit Java.
Combined with -Xmx512M use -d64 to make sure you're running 64-bit VM. On a 64-bit machine I thought for sure I was running 64-bit virtual machine, but no. After installing 64-bit Java the -d64 option works and -Xmx allows much larger memory sizes.
java -d64 -Xmx512M mypackage.Test
Open gradle.properties file in android folder.
Replace this line:
org.gradle.jvmargs=-Xmx1536M
with:
org.gradle.jvmargs=-Xmx512m
Explanation: Max limit from Gradle document:
If the requested build environment does not specify a maximum heap size, the Daemon will use up to 512MB of heap.
I got the same error and resolved this by configuring it in the run.conf.bat
Run the JVM with the configuring run.conf.bat in Jboss5x
If free memory is not available AS you are passing in the statement then please make changes in run.conf.bat
set "JAVA_OPTS=-Xms512m -Xmx512m -XX:MaxPermSize=256m"
I had similar issues. I had installed 32 bit version of Java on a 64 bit machine.
By uninstalling that version and installing 64 bit version of Java. I was able to resolve the issue.
I know there are a lot of answers here already, but none of them helped me. In the end I opened the file /etc/elasticsearch/jvm.options and changed:
-Xms2G
-Xmx2G
to
-Xms256M
-Xmx256M
That solved it for me. Hopefully this helps someone else here.
Suppose your class is called Test in package mypackage. Run your code like this:
java -Xmx1024m mypackage.Test
This will reserve 1024 MB of heap space for your code. If you want 512 MB, you can use:
java -Xmx512m mypackage.Test
Use little m in 1024m, 512m, etc
Sometimes, this error indicates that physical memory and swap on the server actually are fully utilized!
I was seeing this problem recently on a server running RedHat Enterprise Linux 5.7 with 48 GB of RAM. I found that even just running
java -version
caused the same error, which established that the problem was not specific to my application.
Running
cat /proc/meminfo
reported that MemFree and SwapFree were both well under 1% of the MemTotal and SwapTotal values, respectively:
MemTotal: 49300620 kB
MemFree: 146376 kB
...
SwapTotal: 4192956 kB
SwapFree: 1364 kB
Stopping a few other running applications on the machine brought the free memory figures up somewhat:
MemTotal: 49300620 kB
MemFree: 2908664 kB
...
SwapTotal: 4192956 kB
SwapFree: 1016052 kB
At this point, a new instance of Java would start up okay, and I was able to run my application.
(Obviously, for me, this was just a temporary solution; I still have an outstanding task to do a more thorough examination of the processes running on that machine to see if there's something that can be done to reduce the nominal memory utilization levels, without having to resort to stopping applications.)
Must Read
Error :
For the error, "error occurred during initialization of vm could not reserve enough space for object heap jboss"