Docker. Service: Failed to Start and Not Found
Im Really at the Beginning of Diving into Linux World and Its Cli, So I Apologize for My Lack of Knowledge in This Matter. but What Is My Problem? Im Trying to...
Im really at the beginning of diving into Linux world and its CLI, so I apologize for my lack of knowledge in this matter. But what is my problem?
Im trying to install "docker" on my Synology DS418. Following this guide everything runs smoothly until I try to check if docker starts via
systemctl start docker
it reports
Failed to start docker.service: Unit docker.service failed to load: No such file or directory.
When I run
systemctl status docker
it states
docker.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)
This feels like the installation wasnt properly setup, am I correct? What can I do to start docker and run it correctly?
1 Answer
For all following readers with the same confusion: actually it seems that the docker.service is not needed in that case. With a lot of research I managed to install "portainer" via ssh in CLI, so docker works. Im kinda proud of myself that I did it all by myself, yay! Thank you though for the help!