Informatica: Configure Domain (Error Pcsf_46008. Cannot Connect to Domain)
I Have Problem with Configure Domain. I Installed Informatica 10.4 (Server Part) on Virtualbox (Linux) and Client on Windows. When I Try Configure Domen (In...
I have problem with configure domain.
I installed Informatica 10.4 (server part) on VirtualBox (Linux) and client on Windows.
When I try configure domen (in Repository Manager), it appears error
PCSF_46008. Cannot connect to domain.
Domain Name: Domain_sandbox
Getaway Host: 127.0.0.5
Getaway Port: 6005
How fix it?
on Linux side:
ifconfig: 10.0.2.15
Node>General properties>Port: 6005
VirtualBox Port Forwarding rules:
127.0.0.5 6005 - 10.0.2.15 6005
127.0.0.5 6008 - 10.0.2.15 6008
127.0.0.5 6015 - 10.0.2.15 6015
127.0.0.5 6016 - 10.0.2.15 6016
Firewall on Linux is disabled.
Inforamatica serves is running Oracle services is running
From Windows I can connet to Admin panel http//127.0.0.5:6008 and when I try http//127.0.0.5:6005/coreservices/DomainConfigurationService I recive answer: DomainService/InitTime : Sat Jun 12 09:53:59 MSK 2021 but when I try connect from Repository Manager I have error.
also $ infacmd.sh ListServices -dn Domain_sandbox returns:
PC_RS (Repositoru service)
Rest_Operations_Hub
Resource_Manager_Service
Email_Service
Scheduler_Service
PC_IS
2 Answers
i am trying to understand, your infa setup is all fine - repo service, integration service is fine. But you can not connect to Infa from Windows client. Since some specific ports are blocked in Linux, you can not connect to Infa. Infa normally uses a range of ports - details below. In summary, you can open 6001 to 6200 to only the windows server you are working on.
Could you please open all of them?
Here are default ports that infa uses -
- Node - 6005
- Service Manager port - 6006/6007
- Infa admin - 6008/6009
- Application services like Repo manager/repo admin uses a range of ports dynamically - Default is 6014 to 6114.
Also, pls note to open other ports like for other applications. The following services use static port numbers:
- Analyst Service. Default is 8085 for HTTP.
- Content Management Service. Default is 8105 for HTTP.
- Data Integration Service. Default is 8095 for HTTP.
- Metadata Manager Service. Default is 10250 for HTTP. Search Service. Default is 8084 for HTTP.
- Web Services Hub. Default is 7333 for HTTP.
i fixed it!
I put guest ip in "Edit Domain" panel
Getaway Host: 127.0.0.5
Gataway Port: 6005
i takes error pcsf_46008 and the parameter "Getaway Host" changes to Linux Host name.
Getaway Host: ol8.localdomain
Gataway Port: 6005
I set parameters on Virtual Box:
VirtualBox Port Forwarding rules:
127.0.0.5 6005 - 10.0.2.15 6005
It doesn`t help
But then i wrote
127.0.0.5 ol8.localdomain ol8
in hosts file on Windows. and it works.