Mysql Error Sqlstate[Hy000] [1045] Access Denied for User. While Installing Drupal 7 in Localhost
I Recently Did a Clean Upgrade from Ubuntu 14.04 to Ubuntu 16.04. I Could Easily Install Drupal 7 in Ubuntu 14.04 but My Problem Is Arising When I Am Creating...
I recently did a clean upgrade from ubuntu 14.04 to ubuntu 16.04. I could easily install drupal 7 in ubuntu 14.04 but my problem is arising when i am creating a new database for drupal 7.43. I followed instruction from Digital Ocean.
I created a database called drupal
CREATE DATABASE drupal;
created a user called drupaluser
CREATE USER drupaluser@localhost IDENTIFIED BY 'password';
granted the user all the privilages to the database
GRANT SELECT,INSERT,UPDATE,DELETE,CREATE,DROP,INDEX,ALTER,CREATE TEMPORARY TABLES,LOCK TABLES ON drupal.* TO drupaluser@localhost;
Flushed the privileges as per the blog
FLUSH PRIVILEGES;
and exited
I went to localhost/drupal and drupal began the installation process, When i reached the database section i got the following error Message from mysql
"Failed to connect to your database server. The server reports the following message: SQLSTATE[HY000] [1045] Access denied for user 'drupaluser'@'localhost' (using password: YES)."
i have installed xampp 7.0.5 which works well but phpmyadmin is not working so i have decided to take this route but i am stuck
Please adivce.
2 Answers
You should try this command: GRANT SELECT,INSERT,UPDATE,DELETE,CREATE,DROP,INDEX,ALTER,CREATE TEMPORARY TABLES,LOCK TABLES ON drupal.* TO 'drupaluser'@'localhost';
For more info, refer this. Link:
the problem is xampp has created a blank password for the root MySQL database. If you leave the password field empty you should be good to go.