Network Applications Throwing "Servname Not Supported for Ai_Socktype"
Why Are Some Network Application Failing with This Error Message? $ Whois Example. Com Getaddrinfo(Whois. Verisign-Grs. Com): Servname Not Supported for...
Why are some network application failing with this error message?
$ whois example.com
getaddrinfo(whois.verisign-grs.com): Servname not supported for ai_socktype
1 Answer
This can occur when, due to misconfiguration, an unprivileged user does not have read access to /etc/services. Check with:
ls -l /etc/services
It should look like -rw-r--r-- 1 root root ...
The file should be installed from the Priority: important package netbase and have exactly these permissions. If not, fix it with:
sudo chown root:root /etc/services
sudo chmod 644 /etc/services
Nothing about the files contents is confidential or expected to change often. The file lists IANA-registered or common protocol port number associations for TCP, UDP, DCCP, and SCTP.