The Broker Does Not Support Incremental_Alter_Configs
When Trying to Alter a Docker Container Kafka Topic Retention. Ms (In Order to Purge It) I Am Encountering This Error: Error While Executing Config Command...
When trying to alter a docker container kafka topic retention.ms (in order to purge it) I am encountering this error:
Error while executing config command with args '--bootstrap-server localhost:9092 --entity-type topics --alter --entity-name history.data_state_change --add-config retention.ms=1000' java.util.concurrent.ExecutionException: org.apache.kafka.common.errors.UnsupportedVersionException: The broker does not support INCREMENTAL_ALTER_CONFIGS at (CompletableFuture.java:396) at (CompletableFuture.java:2096) at org.apache.kafka.common.internals.KafkaFutureImpl.get(KafkaFutureImpl.java:180) at kafka.admin.ConfigCommand$.alterConfig(ConfigCommand.scala:360) at kafka.admin.ConfigCommand$.processCommand(ConfigCommand.scala:327) at kafka.admin.ConfigCommand$.main(ConfigCommand.scala:98) at kafka.admin.ConfigCommand.main(ConfigCommand.scala) Caused by: org.apache.kafka.common.errors.UnsupportedVersionException: The broker does not support INCREMENTAL_ALTER_CONFIGS
The command I am running is:
kafka-configs --bootstrap-server localhost:9092 --entity-type topics --alter --entity-name history.data_state_change --add-config retention.ms=1000
I am not sure what is this INCREMENTAL_ALTER_CONFIGS and how do I add it, can someone share some wisdom here?
1 Answer
As advised by OneCricketeer - I changed my Kafka image from IMAGE_KAFKA := wurstmeister/kafka:2.11-2.0.0 to IMAGE_KAFKA := wurstmeister/kafka:2.13-2.7.1 which did the trick.