Ubuntu Server 16.04 and Active Directory
I've Been Following the “Sssd and Active Directory” Documentation in Order to Try and Add an Ubuntu Server to Our Windows Ad Domain for User Authentication...
I've been following the “SSSD and Active Directory” documentation in order to try and add an Ubuntu Server to our Windows AD domain for user authentication.
Configuration goes well until the point at which I need to start the SSSD service.
The service will not start, it after checking journalctl the following error is given:
Failed to read keytab [default]: No such file or directory
I would guess this is being caused by:
kerberos method = secrets and keytab
inside /etc/samba/smb.conf but no information is given in the documentation about other possible values this method can be set to.
1 Answer
I found a solution: when you restart the services in the how-to guide you can’t start the SSSD daemon cause the error. Just join your machine to your AD how the next steps describe. After that start SSSD.
In addition, add
ldap_id_mapping = true
to your sssd.conf if you don’t have Unix IDs in your AD, so SSSD calculates the IDs.