Unable to Start Mysql Server
Running Windows 7 64-Bit. I've Been Unable to Start an Instance of Mysql 5.6 Server. When I Attempt to Start It from Within the Mysql Workbench, I Get This...
Running Windows 7 64-bit.
I've been unable to start an instance of MySQL 5.6 server. When I attempt to start it from within the MySQL workbench, I get this:
2013-11-23 14:05:07 - Checking service status of instance MySQL...
2013-11-23 14:05:07 - Status check of service 'MySQL' returned stopped
I've tried manually starting the Windows service. Following advice that worked for others with the same problem, I've configured the service to log on as "Local System account". No dice; it throws this:
error 1053: the service did not respond to the start or control request in a timely fashion
I've also tried disabling my firewall, and completely reinstalling MySQL server.
It should perhaps be noted that (I assume as a result of all this) I also cannot log into the MySQL command line client. It tells me:
Can't connect to MySQL server on 'localhost' (10061)
This is my first time trying to set up a MySQL server, so perhaps there's just something I've missed. If so, I'm unsure what it is.
16 Answers
I had the same issue. Try this, it should work!
Right click on MySQL Notifier -> Actions -> Manage Monitored Items
Highlight the MySQL56 entry and click the delete button
- Click the add button -> windows service
- Scroll down and look for MySQL56
- Highlight it and click ok
Try manually start the service from Windows services, Start -> cmd.exe -> services.msc. Also try to configure the MySQL server to run on another port and try starting it again. Change the my.ini file to change the port number.
You should start by checking the error log and/or the startup message log when managing the instance using MySQL Workbench. There could be clues as to what is going wrong, which may be different than this scenario.
When I had this issue, it was because I used a space in the service name during installation. While it is technically valid, you should not do that. It seems that the MySQL Installer (and MySQL Notifier) does not put the name in quotes which causes it to use an incorrect service name later on. There are two ways to fix the problem (all commands should be run from an elevated command prompt).
Must Read
Reinstall the server
The first is to simply reinstall MySQL Server 5.6 using the default, no-space service name MySQL56.
The installer uses the same value for the service name and service display name. The name that I had originally specified was for a display name, when it should have been a simple service name. After installation, if you so choose, the display name can safely be changed to use spaces and other characters by using:
sc config MySQL56 DisplayName= "MySQL 5.6"